Basic Data analysis with ODV



Save the OSD file in Documents\ODV\DATA with the

filename osd_wod.gz.

Similarly save the CTD and PFL files this folder.

Please copy all the data provided, to the folder
User\Documents\ODV\Data for ease of

handling/importing during this training session



Options:

To view the full screen map, select View > Layout

Templates > Full Screen Map.

To save the current view, select View > Save View As
and name the view station_map.

To save the distribution map as an image, right-click on
the map and select Save Map As then specify the file
name and select the file type.



Other Options:

Change Projection
Z.0oom to desired

Add graphic objects
Explore menu options
Keep in mind:

* Save views and plots frequently, whenever needed

* Undo options are limited



Task:

* Import the other WOD datasets (CTD, PFL) into the

existing collection.



Basic plotting using ODV



Part 1:
Station plot



1. Draw a station plot:

Open the OSD collection

previously created.

Select View > Layout Templates
to show a list of predefined
window layout templates.

Select | STATION Window.

Full Screen Mep

T STATION Windew
2 STATION Windiows
6 STATICN Windows

1 SCATTER Window
2 SCATTER Windows
6 SCATTER Windows

1 SECTION Window

1 SECTION Windows
3 SECTION Windows
5 SECTION Windows
6 SECTION Windows

1 SURFACE Window
2 SURFACE Windows
3 SURFACE Windows
5 SURFACE Windows
8 SURFACE Windows
11 SURFACE Windows

1 SURFACE + | SCATTER Windows
S MIXED Windews

From View File




Press Enter to plot the

default station indicated ' =—
by the small red cross on o L

the map. §- /

Select other stations on -l

the map to plot their |

profiles, temporarily, on [

the graph.
Double-click on any

4°N |

station to make it appear

permanently on the plot. .|
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To change the x or y
variables in the station
plot, right click on the ‘

station plot and choose

X-Variable or Y- Varlablc

Vareble: Window |

For example, select X- 52?

Variable and choose | g::m

Salinity to display the
salinity profile.

2. Adjust the variable in a station plot:

Defos

10 15 20
Temperature [degrees_C]




Redraw F5
Save Plot As... Ctrl+5

Save As Interrupted Map...

Zoom
Z-Zoom
nght CliCk on the plOt Auto-Zoom In Ctrls-+
Auto-Zoom Out Ctrl+-
and ChOOSG Set Ranges Move to Foreground

Move to Background

then set the range for the ... et
X and Y variables. —

X-Variable
Y-Variable Y
Z-Variable £
For example, set the e  [samannse

¥ Axis: Salinity [psu]

depth range to 0 - 1000m sampleFiter | o

Properties... Alt+P

or the salinity range to 34
to 37 psu. R

Right click and select
Full Range to set the full

range of the values.




3. Edit station plot properties :

To change the figure
properties, select the
station on the map then
right click the map
window and choose
Manage Pick List > Edit
Pick List to change the
symbol type and colour
and the line.

|

Redraw F5
Save Map As... Ctrl+5
Save As Interrupted Map...
Zoom
Auto-Zoom In Ctrl++
Auto-Zoom Out Ctrl+-
Valid Domain
Full Domain Ctrl+F
Global Map
Current Station by P
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To change the symbols of
the stations on the map,
right click on the map
and select Properties >
Display Style and change

the colour and size of the

=)

Under Annotations you

symbol.

can add annotations
about the cruise and

station labels to the
stations on the map
window.

Redraw F3
Save Map As.. Ctrl+5
Save As Interrupted Map...

Zoom

Auto-Zoom In Ctrl++
Auto-Zoom Cut Ctrl+-
Yalid Domain

Full Domain Ctrl+F
Global Map

Current Station by
Station Filter... Alt+5

Manage Pick List

Manage Secticn

Extras '-
Alt+P
e "




Other Options:
* Add graphic objects to station plot
* Text (Annotation)
* Symbol
. Polygon

Task:

* Make station plot with oxygen on X-axis (oxygen

profile with depth)



4. Station metadata and data

* The top panel (Station ID)
contains the metadata about
the cruise.

* The metadata includes the
Accession No, cruise, station,
position, data and time.

* The second panel (Sample)
lists the depth and values of
each variable measured at the
station.

Station ID: 15599

Accessio.. 13213

Cruise WOD18_Us036398
Station 17902454 (B)
Position 67.649°E / 18.923°M
Date 10 December 2016
Time 06:53

Depth Ra... [3- 1188]

Bot. Dept...

OCL Crui... 36398

Originato..., 2901478

sSample: 13 [ 47

=X

1: Depth [m] 65

2: Temperature [degrees... 27.14
3 Salinity [psul 36,870
4: Coeygen [pmol kgl

5: Phesphate [pmelSkg]

B: Silicate [pmol/kg]

7: Mitrate [pmelSkg]

: Mitrite [pmelSkg]

S: pH

10: Chlerophyll [pgl]

11: Plankton/Biomass

12: Alkalinity [megsl]

13: MO2+MNO3 [pmolikg]

14 pC02 [patm]

15: +C02 [mmols 11

== = = R == [ == [ == [ = I = = [ = IO = [ = i = Y = ) =]

b

Isosurface Values

Lengitude

Latitude

Tirme [yr]

Day of Year

Depth [m] @ Depth [m]=first

1=

Temperature [degrees_C] @ Depth [m...

67.649
18.923
2076.941
345

-

Lal




Part 2:
Scatter plot



1. Draw a scatter plot:

Select View > Layout Templates
to show a list of predefined
window layout templates.

Select | SCATTER Window.

Station Filter...

Derived Variables...

Isosurface Variables...
Window Properties

Window Layout
Layout Templates

Save View As...
Save View

Load Views...

Browse Session Log File

Settings...

Alt+S

Alt+D

Alt+W

Shift+L

Full Screen Map

1 5TATION Window
2 STATION Windows
6 STATION Windows

1 SCATTER Window
2 SCATTER Windows
6 SCATTER Windows

1 SECTION Window
2 SECTION Windows
3 SECTION Windows
5 SECTION Windows
6 SECTION Windows

1 SURFACE Window

2 SURFACE Windows
3 SURFACE Windows
5 SURFACE Windows
8 SURFACE Windows
11 SURFACE Windows

1SURFACE + 1 SCATTER Windows

5 MIXED Windows

From View File

F8

F9

F10

F11

F12



Scatter plot:

ﬂ Coean Dats View - ChiUsers\usen Docements\ 00V \catlections'\osd_sll_mda_wodl ) = o x
Fie Collection Yiem Impent Epont Toech Hep

CRCROE - B et o) et ]
o | 1Accessun Number 158 -
Cruse WO INSSODS
Station 167065 (8)
Postion RATE! RN
0 - Date 2 Deswmber 1962
Time 2
5 Depth Range |m| - 1%0)
Bct. Depth {m] K0
OCL Crase Number 3
Cngmator's Crune
1000 Origauater's Station »
‘Sample:9 ] 18 } QU
4 1: Dapth [m] 200 |
2 Tempesature fdagrees, 1857
. & Sabney (psu) 13 )
4 Oxygen [mud'by| 0
% Fhotpbate [pmolivg: 0
5 & Sdicate [praliogl 0
e T Ntrate [umolig] 0
p B Ytrte molivg) 0
A 3 o 0
10 Chiorep h® [307) 0
11: Plarkecn/Bioman 0
, 12 Alkalivity Imeq/T] i
' 1) NOZ+NOJ [pmokkg] 0
. 34 pCO2 fpstm] o
add i 131C02 Immeel 0¥l
3 Isasurface Vahurs
] é ‘.r.-*u(vnk »
o : g, Lntnude
|| Time [y] »
0 20 40 60 80 Ding of Year s
Temperature [degrees_C] Depth [m] © Depth (m)=frat 0
ks ’ ¥ Tempesstioe [ Segrees C] @ Desth jm.. 2223 |
| Ready . Carvens G857 1545 [ |- [\$357/ |§.\:7.D-‘hm" S B e

n O Type here to search




2. Plot a Temperature-
salinity scatter

Right click on the scatter
diagram

Change the X-Variable to
Salinity

Then change the Y-

variable to Temperature

Redraw
Save Plot As..,
Save As Interrupted Map...

Zoom
Z-Zoom

Auto-Zoom In

Auto-Zeom Out

Move to Foreground

Move to Background

Full Range
Set Ranges

X-Variable
¥-Variable
Z-Variable
Extras

Sample Filter
Properties...

Redraw
Save Plot As...

Save As Interrupted Map...

Zoom

Z-Zoom

Auto-Zoom In

Auto-Zoom Out

Move to Foreground

Mave to Background

Full Range
Set Ranges
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¥-Variable
Z-Variable
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Sample Filter
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3. Set axis limits

Redraw E5 |
Save Plot As... Ctrl+5 Set Auis Ranges
" . Save As Interrupted Map... ] ¥ Axis: Salinity [psu]
Right click on the scatter -
Zoom
Maximum: |4C|
7-foom

diagram > Set ranges

Set temperature range to
0-35 and salinity range to
30-40 to ignore the
outliers/ bad data

Auto-Zoom In

Auto-Zoom Out

Move to Foreground

Move to Background

Full Range
Set Ranges

X-Variable
Y-Variable
Z-Variable

Extras

Sample Filter
Properties...

Ctrl++
Ctrl+-

Ctrl+F




4. Change display properties

Right click on the scatter
diagram > Properties >
Display Style

Change the Symbol size,

Symbol color, and Line

width s

Zoom

Audo Zocen n
Zato-Taem O
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Full Raage
Set Ranges
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5. Derived variables

Go to Top Menu > View >
Derived variables

Select Potential
temperature and set
reference pressure as ( db.

Then click Add > OIK

Similarly select and set
potential density anomaly

E Ocean Data View - Ch\Usershuser\Documents\ 0DV collect
File Collection View Import  Export  Tools  Help

+ 9 [

Undo L4
Redo L4
Station Filter... Alt+5
Derived Variables... Alt+D

lzosurface Variables...

Window Properties r
Window Layout Alt+W
Layout Templates »

Save View Ac...
Save View

Load Views... Shift+L

Browse Sessicn Log File

Settings...

Avesch Defred

Potertisl Temper stsre & eyl Adsbatc Lopse Rate I




6. Plot Potential
Temperature vs. salinity

Right click on the scatter
diagram

Change the Y-Variable to

drvd:potential temperature

Potential Temperature 6 [degC]

40

w
=3

N
oS

~
S

25

30
Salinity [psu]

35

S Oceen Dets Vew



7. Overplot with another
variable

Right click on the scatter
diagram

Select Z-Variable as Oxvgen

S 8

-
A~

Potential Temperature 0 [degC]

i

Oxygen [umol/kg]

25

30
Salinity [psul

35

150

100



Other Options:

Add isopycenals from FExtras

Save view from Menu > Save
View As. Later Load this
view from Menu > Load
Views

Potentlal Temperature 0 [degC]

T -

8

8

-
o

150

100



Part 3:
Section plot



n Ocesn Dats View - CAUvery e\ Decuments\ OOV cellecticns, 0DV _COLLECTION {2019-07-02T10-36-39
Fde Cobection View Import DBpos  Tools MHep

Section plot: e m =
Select View > Layout Templates e g

to show a list of predefined e .

Settings..,
§ SCATTER Windows

window layout templates. o

Select 1 SECTION Window. e

3 SURFACE Windows
5 SURFACE Windows
£ SURFACE Windows
11 SURFACE Windows

1 SURFACE « 1 SCATTER Windows
5 MIXED Windown

Freen View Fie




1. Define a geographic section:

Right-click on the map, and select Manage Section > Define

Section.

Click on any point to start section. A red dot appears to mark

the start point.

Draw a line to the

end point of the -
section and double Gulsite

click to end section.

L Ve v Yar er so0o0BUE
e e P Tioe  Dutn Mosied
v Do | IO e S VAW T

Provide Section
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bathymetry > File
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2. Draw a Section Plot:

* Right click the section plot and select X-Variable > Section
Distance. The section is displayed as coloured dots with the
temperature scale bar on the right.

*  Setrange of X axis up to 4500 m to show the ocean floor.

L | aoe o \ ew [-§
Temperature [degrees_C]

- San I

U o on B W il \ —a—

Temperature [degrees_C]

R DA TR, K T O |




3. Data interpolation/Gridding:

Right click the section plot and select Properties

For Data, select Reverse Range X-Axis so the view is the same
as the station map.

In Display Style, use Weighted-average gridding, set X scale-
length to 100 and Y scale-length to 50. Uncheck Draw Marks.

Experiment with different length scales to get desired
smoothness while preserving the data structure.

In Contours, check Do Contours and click on the icon << to
create contours for the z variable



Weighted-Average Gridding
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To save the settings for the section, right-click on the
station map and select Manage Section > Save Section
As. Accept the location and filename extension and
enter the name AS_offshore_southwest. (for access
later)

To save the view of the data, select View > Save View
As with the name India_southwest_section.

Task:

Change the section variable to oxygen, and set ranges
of the axis to view the continental shelf.



Part 3:
Surface plot



n Ocesn Data View - C\Usersiuser\Documents\ 00\ collections ODV_COLLECTION_(2019-07-02710-36-39)
File Coflection VYiew Impot Export Tocls Help

Surface plots: e -
. :;?m : o L2 Full Screen Mep ]

Select View > Layout Templates g i
to show a list of predefined ey

window layout templates. i

5 SECTION Windows
6 SECTION Windows

Select 2 SURFACE Window. st

2 SURFACE Windows
3 SURFACE Windows
3 SURFACE Windows
8 SURFACE Windows
11 SURFACE Windowy

1 SURFACE + 1 SCATTER Windows
5 MIXED Windows

From View File




1. Draw Surface Plot:

Salinity [psu] @ Depth [m]=first

Right click on one surface =

plot and select Z-Variable

16°N

> Temperature. :: s q’g
o A

Right click on the other Y ,:, :5,

surface plot and select Z-

Variable > Salinity. .

Set ranges of 7 axis for

temperature as 25 to 35
and salinity as 25 to 40.

65°E 70°E 75°E



nenurface Virabie

2. Isosurface variables:

Select View > lsosurface
varaible

Under New, select Temperature

@ Depth = enter 100 m. Click

Add, Ok

Right click the salinity surface
plot, select Z-variable and select

Temperature at depth=100

Set ranges as same limits for
both the plots, for easier
comparison.

= Tew e g * e Lowmh .

Aeats (wtwe

Longta
Lt

Tore )

Oay of Yew

Cwp® o] & Depeh (] =t
Torper abae [Megeer T @ Sep | vhw
Serery i O Owp® e[ ofrat

Cwvge Laeaingl § Deats (v =tout

- e B e L

- o o

Temperature [degrees_C] @ Depth [m]=100




3. Data interpolation

Again go to View > Layout
Templates, select 1 SURFACE

18°N

. 16°N |
Window.

14°N

Right click on the figure and

12°N

select Z-variable as Oxvygen. Set

10°N

Ranges as per data variability.

Again, click properties by right
clicking, go to Display Style,
select DIVA gridding.

Uncheck Draw Marks. Check
Hide Bad Estimates, Do color
shading and Exclude outliers.

Oxygen [umol/kg] @ Depth [m]=first

100
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To save the view of the data, select View > Save View As
with the name india_surface_oxygen.

To save the figure select Save Plot As by right clicking,
and save into desired format (.png, .jpg, .ps, .tif etc)

Task:

Add another isosurface variable ‘oxygen at depth=200 m’
to see the Arabian Sea oxygen minimum zone.



