Examples



Etopo1 bathymetry



Go to File > Open and select the nc file etopol.nc

Go through the 4 steps of netcdf setup and include the
bandl (which is the bathymetry) to the meta variable list
on RHS.

Subset the dimensions in step 3 to Use All the increments

of the data
Band1 @ Dummy=first
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U wind from NCEP



Go to I'ile > Open and select the
nc file uwind_monthly_mean.nc

Go thought the 4 steps of netcdf
setup and include the uwind
variable to the meta variable list

on RHS.

Use time as primary selected
variable

After plotting, right click and Save
as Interrupted Map.

Interrupted Map Properties

Title: |Zonal winds

Label: [NCEP|

Copyright: |Linta

FontSize:

Draw south polar map
Transparent background

Resolution: |499 dpi =
Draw north polar map
=
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Check out:

* Different types of projection
* Different options of palette

* Open a previously opened netcdf file, such as
etopol.n

* EKExplore colorbar with fixed intervals based on
contours, in a surface plot

* Drag and resize figure using Window Layout
mode



Cyclone track from JTWC



Go to Iile > Open and select the csv file
ockhi_cyclone_track.csv

Associate the variable and assign data fields.

(reate isosurface variable of pressure at time equals first

pressure @ Time=first

990

15°N

980

970

10°N

960

950

Ocean Data Wiew

5°N

T0°E 75°E 80°E



Additional options in ODV



Part 1:
Basic Statistics



Open previously created
osd_wod_india.odv

mmmmmmm

To view the basic statistics, make a

mmmmmmm

scatter plot of Chlorophyll vs oxygen

X Histogram

Y Histogram Z Histogram

Right click on the figure, select [ixtras ==

> Statistics

Select Y Histogram to see the
distribution of chlorophyll

Select X/Y distribution to see the data

distribution .
For curve fitting, select Linear lLeast E
Square fit , construct curve and show _E:; ;
curve i
After closing the statistics toolbox, to |
remove the fitted line from the figure, -

right click on the line and select delete
obilect
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Orienta Y (X)
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Part 2:
Quality control



To edit the data in a single profile, right click on
the values in the Sample window on the right

middle and select Edit Data.

Change Value or change quality flag for the profile.

Select Idit sample to modify all the variables for
the specific location.

We can also assign quality flags for the currents
sample or all samples of the profile

Daf Edit Quality Flags
Data |
Select new quality fiag for 1 samples I:l
Depth [m] Oxygen [omolfkg] Errors Oxygen [0 QF A R * a
11w 207 0 3 0: accepted value
4 | 1: range outlier (outside of broad range check)
4 0 205 9 2: failed inversion check
5 25 o 3: failed gradient check
6| | 4: observed level bullseye flag and zero gradient check
6 30 214 0 1 5: combined gradient and inversion checks
7 4 129 1] 6: failed range and inversion checks
s 50 9 8| |7: falled range and gradient checks 3
Change Value o| |8 falled range and questionable data checks Change Value
9 74 93.2 0 9: failed range and combined gradient and inversion checks 3 —
0 75 B tnternewds.. 7 b4 Change Error Value 1 | EALS
1 L
s e Oxygen [umolkg] @ Depth [m] = 10: elete Value(s)
2 100 Delete Value(s) 1 E
207 i K
13 125 I Delete Error Value(s) pte Error Value(s)
w4 |07 25 Cance 1 I
15 150 0 Change Quality Flag(s) 1 Jge Quality Flag(s)
15 175 1} 1
17 1% EX] 0 1
18 200 ] 1
19 295 3.9 0 1
a0 3 5 n hd L2l
1of 31 samples selected 1
Select Al Invert Selection
. cas | F
Help oK Cancel Cancel

Station ID: 497

Accession Number 497 2
Cruise WOD18_US016131
Station 405430 (B)

Position 67.95°E / 19.98°N
Date 20 August 1963

Time 2312

Depth Range [m] [0 - 3049]

Bot. Depth [m] 3091

OCL Cruise Number 16131

Originator's Cruise

Criginator's Station

v
Sample: 3 / 31 [N

1: Depth [m] 10 0 -~

2: Temperature [degree.. 27.36

3: Salinity [psul 36.430 0

4: Oxygen [ Edit Data... Shift+E

5: Phospha Edit 5ample Data...

G Silicate ) Assign Quality Flag 4

7: Mitrate [prmowkeg) U

& Nitrite [umol/kg] 0

% pH 0

10: Chlerophyll [pg/1] 0.23 0

11: Plankton,/Biomass 0

12 Alkalinity [mea/1] 0

13: NO2+MNO3 [pmol/kg] 0

14: pCO2 [patm] 0

15:+CQO2 Immel/11 0 b
Isosurface Values
Longitude 67.950 ~
Latitude 19.980
Time [yr] 1963.636
Day of Year 232
Depth [m] @ Depth [m]=first 0
Temperature [degrees_C] @ Depth [... 27.34

v



To perform quality control first
plot a depth vs salinty scatter plot

Go to Tools > Find Outhiers. Give
a range 30 to 33 psu for salinity
and select find values outside this
range.

An outlier list will be generated,
which can be viewed later in
notepad.

Select View and Edit outliers and
Ilag them and Keep them, Apply
to all. You can also delete them,
which is not recommended.

Inspect the profiles to see the
flagged data points

Find Qutliers

Scan Variable

1: Depth [m]

3: Salinity [psu]

9: pH

16: Tritium [TU]

2: Temperature [degrees_C]

4 Oxygen [~Sm~#molfkg]

5: Phosphate [~$m~#molkg]
6: Silicate [~$m~#mol kg]

7: Nitrate [rSm~zmolkg]

8: Mitrite [~Smr~zmolka]

10: Chlorophyll [~&m~zg/l]
11: Plankton Biom;
12: Alkalinity [meq/l]

355

13: NOZHNO3 [~ #
14: pCOme_2 [rom~eFatm]
15: tCO~_2 [mmol ]

17: Helium [nmal/kal

Range: |30

[REE]

Action: | find values outside ran

Sample Range

ge

Depth [m]: |D

| - [a500

|dentifying Cutliers

36195 outlier(s) found.

[ view outlier list
Inspect and edit outliers

Outlier Action

Station=[4: WOD18_US032933 13574769 (B)] Sample=1 Value=37.3 QF=0

(® Flag as

range outlier (outside of broad range check)

() Delete value

Apply

o

Apply to Al



Part 3:
Export data



Export the data using FExport > Station Data > 0DV
Spreadsheet file

Export the QC modified data in the scatter window using
Export > XYZ Window data, into a text document

Make a gridded surtace plot of salinity at 300 m and save
this isosurface data into a text file using xport >
Isosurface data

The interpolates values will not be exported

XYZ window data is column data and is reusable



Part 4:
Ocean Data Calculator



Go to Iile > Tools

and select Ocean
Calculator

Select variables form
the RHS and provide
input variable values
on LHS to get the
specified derived
variables at specific
locations.

You can type any
values under the
Input values tab.

E Ocean Calculator

Input values

Variable

Pressure [dbar]
Temperature [degC]
Practical Salinity [psu]
Longitude [degE]

Latitude [degh]

Value

1100

29

33

30

Result: 3987.38121

Help Settings

| Evaluate |

HCO3-{ALK,DIC) [umoljka]

In situ Density Anomaly o [kg/m?]

In situ Temperature [degC]

Latent Heat of Evaporation [kJkg]

Latent Heat of Melting [kJ/kg]

Meutral Density yn [ka/m3]
Omega_A(ALK,DIC)

Omega_C(ALK,DIC)

Oxygen Saturation [%]

Oxygen Saturation [umol kg]
pCO2(ALK,DIC) [uatm]

pH{ALK,DIC)

Potential Density Anomaly o [kg/m?]
Potential Temperature 8§ [degC]

Practical Salinity from Absolute Salinity [psu]
Practical Salinity from Conductivity [psu]
Preformed Salinity 5% [g/kg]

Pressure from Depth [dbar]

Reference Salinity SR [g/kg]

Revelle Factor{ALK,DIC)

Saline Contraction Coefficent BE [10-3 kg/q]
SF6 Partial Pressure [pptv]

SF6 Saturation [%:]

SF6 Saturation [fmolfkg]

SF6 Solubility F [malkg/atm]

Sound Speed ¢ [m/s]

Spedific Heat Capadty Cp [J/(kg degC)]
Spedific Volume [cm3/g]

Specific Volume Anomaly & [10-6 m3/kg]
Spiciness n

Thermal Expansion Coefficient a® [10-6 K-1]
Thermobaric Coefficient TEb [10-12 1/(K Pa)]

Description

Temperature and Salinity.

and Guides Mo. 56, UNESCO (English), 195 pp.

Spedific heat capacity C~_p for seawater at given Pressure/Depth,

Ref.: I0C, SCOR and IAPSO, 2010, The international thermodynamic
equation of seawater - 2010: Calculation and use of thermodynamic
properties. Intergovernmental Oceanographic Commission, Manuals

Close




Part 5:
Overlay plots



Open the osd_wod collection
previously created.

Depth [m]

Detfine a new section along a
thickly data populated
region. A section can be a
curve or any zigzagged
feature.

Plot temperature as 7
variable and interpolate data
using weighted average

oridding.

Temperature [degrees_C]

-
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600

Temperature [degrees_CJ
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To overplot salinity contours on temperature, go to I'ile >
View > Window Layout

Or alternatively, click on the # icon on the menu bar.

Now right click on the image, select Create overlay
window.

Go back to figure, again right click, select properties,
make sure the data tab shows the new variable — salinity

Go to contours, select do contours and add a range of
contours, with increments

Go back to the figure, right click and select Accept



File Collection = View

Import  Export  Tools  Hely

+| =] [ Undeo 4
Redo L4 Maowe [ Resize
. i Delete Window
Station Filter... Alt+5
i . Create New Window
Derived Variables... Alt+D
. Create Overlay Window
Isosurface Variables..,
| ) . Move to Foreground
Window Properties 4
Move to Background
Window Layout Alt+W
Properties...
Layout Templates 4
) K-Variable
Save View As... .
¥-Variable
{ Save View
. Z-Variable
Load Views... Shift+L
. . Accept
Browse Session Log File
Cancel
Settings...
Properties Window 2
General Data Display Style Contours Color Mapping DIVA Settings
Already Defined New
5 —
31
2 =< Increment
33
24 = 1 End
35
Line Labels
[ 17 ~ | |apt =
solid v
Fill
<<
auto-create (none) s

Do contours

[ apply to all windows with this Z-variable

3: Salinity [psu]

Help

Care

Ctrl+R
Del

Alt+P

E Select Variable

Z-Axis Variable of Overlay-Window

Q

(none)

1: Depth [m]

2: Temperature [degrees_C]
Salinity [psu]
Oxygen [umol fkg]
Phosphate [umolkg]
Silicate [pmol/kg]
Nitrate [pmol/kg]
Nitrite [umolka]

pH
Chlorophyll [ug/]
PlanktonBiomass
Alkalinity [meqg/l]
MO2+MO3 [umol/ka]
: pCO2 [patm]

: tCO2 [mmol/T]

: Tritium [TU]

: Helium [nmolfkg]

: @3He [%%]

¢ B14C [%o]

20: G13C [%d]

21: Argon [nmelfkg]

22: Neon [nmol/kg]

23: CFC11 [pmolfka]
24: CFC12 [pmolfka]
25: CFC113 [pmol/kal

CELUPh RO e Do e

[ reverse range

Move / Resize Ctrl+R.
Delete Window Del

Create New Window

Create Overlay Window

Move to Foreground

Move to Background

Properties... Alt+P
K-Variable X
Y-Variable Y
Z-Variable z
Accept Enter
Cancel Esc




E Ocean Data View - C\Users\user\Documents\ 0DV data\ ODV_COLLECTION_(2019-08-08T14-58-52) — x
File Collection View Import Export Tools Help
+| 9] (O] H W] [/ Default xR Station ID: 1

Accession Nu... 1 L
Temperature [degrees_C] Cruise WOD18_GB012994

Station 15665472 (B)

Position 66.65°E / 15.93°N

Date 01 June 1800

Time

Depth Range [... [0-0]
Bot. Depth [m]

OCL Cruise N... 12934
Originator's C...
Originator's St...

Sample:1 /1 |Q

Depth [m]

1: Depth [m] 0 0 -~
2: Temperature [degr... 82.00 1

3: Salinity [psu]

4: Oxygen [pmol/kg]

3: Phosphate [pmol/k...

6: Silicate [umol/kg]

7: Nitrate [umol/kg]

8: Nitrite [umol/kg]

G pH

10: Chlorophyll [pg/1]
11: Plankton/Biomass
12: Alkalinity [meq/1]
13: NO2+MNO3 [pmol/...
14: pCO2 [patm]
15:+C02 [mmal/ll
Isosurface Values
Longitude 66.650
Latitude 15.930
Time [yr] 1800.414
Day of Year 152

65°E T0°E 75°E Depth [m] @ Depth [m]=first 0

Temperature [degrees_C] @ Dept... 82.00
£ > W

Colimit T I VT N U By

Window 2 on 1: 48,136/ 5 RW| -|- | - |3050 / 3050: Default *

- = 1507
O Type here to search a . & T ) ENG 1

40 50 60 70 80
Section Distance

20°N

18°N

16°N

oo o o o o o o o o o o O

14°N

12°N

10°N

Ready

08-08-2019



* Overlay window will be active only after data
interpolation.

* To go back to the filled plot of temperature contours to
change its properties, now it can only be accessed through
File > View > Window properties > Window 1.

* For the window 2 (salinity contours) remove the colorbar
from Properties > Data > colorbar settings > Position >
No colorbar.

Task:

* Repeat the same for a surface plot, Reject the outliers.



ﬁ Ocean Data View - C:\Users\user\Documents\ 0DV data\.ODV_COLLECTION_(2019-08-08T14-58-52)
File Collection View Import Export Tools

+ O O H m /S

8\

Station ID: 574

20°N

18°N

16°N

14°N

12°N

10°N

65°E 70°E

Salinity at surface

20°N

18°N

16°N

14°N

12°N

10°N

Temperature [degrees_C] @ Depth [m]=first

P

@l 7
LS
iy

“Ocean Data View/ DIVA

40

30

20

10

Accession Number
Cruise

Station

Position

Date

Time

Depth Range [m]
Bot. Depth [m]
OCL Cruise Mumber
Originator's Cruise

Criginator's Station

574 ~
WOD18_IN000416
444365 (B)

72.483°E/ 17.965°N

22 March 1963

15:54

[1-40]

42

416

25

Sample:1 /5

|Q

1: Depth [m]

2: Temperature [degre...
3: Salinity [psu]

4 Oxygen [pmol/kg]

3: Phosphate [pmol/kg]
6: Silicate [pmol/kg]

7. Mitrate [pmol/kg]

& Nitrite [pmel/kg]

9 pH

10: Chlorophyll [pg/1]
11: Plankton/Biomass
12: Alkalinity [meq/1]
13: NO2+NO3 [umol/kg]
14: pCO2 [patm]

15: £C02 [mmal/11

1
26.73
35.628
17.0

a0 o o o o o o O O o o O O O

Isosurface Values

Longitude
Latitude
Time [yr]
Day of Year

>

Comlimit T 1 F Denile Lonel

72483 0~
17.965
1965.221

a

Depth [m] @ Depth [m]=first 1
Temperature [degrees_C] @ Depth ... 26.73

oy ac ean

Ready

O Type here to search

Window 2 on 1: 63.35°E / 20.68°N

- 3050 / 3050: Default *

A o T o

ENG

1518 |:|
08-08-2019




Hovmoller Diagram

Try a surface temperature

plot with gridding.
Change the y variable to

time in years and zoom
into the figure to get the
desired filled region.

This 1s similar to a
Hovmoller (time-
longitude) diagram, but
without area averaging.

1990

1980

Temperature [degrees_C] @ Depth [m]=first

68°E 70°E 72°E 74°
Longitude

M Ocean Data View / DIVA

<. 35
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30
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25

22.5

20



