Add different formats of data into
oDV



Part 1:
ARGO netCDF Data



E Ocean Data View - Ch\Users\user\Documents\ODV\collecti

File Collection View Import

Mew... Ctrl+N
Open... Ctrl+ 0
Open Remote...
° Close Ctrl+F4
]_. Create a new COllecthn Execute Batch File...
Save Canvas As... Ctrl+5
Recent Files L4

* Open the PFL collection ~

previously created.
OR

e Select File > New to create a new
profile float based collection
named pfl_all_india_wod.odv in

the folder
Documents\ODV\Collections

. Select World Ocean Database

under Definition of collection
variables window.

Expert Tools Help

E Create Mew Collection

X

Loak in: C:\Users\user\Documents\ODV\collections > 0 @ @ E]
- Desktop Mame Size Type Date Modified =
\_‘_:-| Docume E pfl_all_liberia_wod13.0dv 2KB odvFile 18-03-... 15:36

E pfl_all_india_wod13.0dv 2KB odv File 30-06-...12:44
ooV | |5 osd_all_india_wod13.0dv 2KB gdvFile 28-06-.. 10:15
ocean E ODV_COLLECTION_argo.odv 2KB odvFile 21-03-..17:
E ODV_COLLECTIO..12-46-26).0dv 2KB odvFile 30-06-..
collectic | = 0DY_COLLECTIO...04-02-19).0dv 2KB odvFile 28-03-
E Arabian_Gulf_csv.odv 1KB odvFile 21-03-.
pfl_all_liberia_wod13.Data Fil..der 29-03-...
pfl_all_india_wod13.Data Fil..der 30-D6-...
osd_all_liberia_wod13.Data Fil...der 18-03-..
osd_all_india_w...-06-28T13-01-32 Fil...der 28-06-...
osd_all_india_wod13.Data Fil..der 28-06-. d
ODV_COLLECTION_argo.Data Fil..der 21-03-..17:
ODV_COLLECTIO...2-46-26).Data Fil...der 30-06-...
< > ODV_COLLECTIO. . 4-02-18).Data Fil...der 28-03-.. w
File name: pfl_all_india_wod13.0dv | I Save
Files of type: | Collection Files (*.o0dv) Cancel
Creating collection...
Definition of collection variables | Q
Use .txt, .odv, .var or other file as template
User specifies variables manually
----- -standard templates———
Argo Profile
Argo Profile (induding intermediate variables)
Argo Trajectory
GOCD (Global Ocean Currents Data)
GOSUD {Global Ocean Surface Underway Data)
GTSPP (Global Temperature-Salinity Profile Program)
Medatlas Profile
Medatlas Time Series
MNODC 5D2
WOCE ADCP
WOCE Current Meter
WOCE Sea Level
WOCE Subsurface Float
WOCE Surface Velodty
WOCE WHP Bottle
WOCE WHP CTD
World Ocean Database
[] customized collection creation Cancel
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2. Download data from Coriolis

The Coriolis data centre (http://www.coriolis.eu.org/Data-

Products) provides quality-controlled in-situ data in real-time

and delayed modes

From the Coriolis data products site select Data Delivery >
Make your own Data selection.

Enter the coordinates and the start and end dates as shown.

Top (latitude): 10 degrees
Bottom (latitude): 5 degrees
Left (longitude): 65 degrees
Right (longitude): 75 degrees

Start Date: 01/01/2017
End Date: 01/01/2018
Select Vertical Profiles > Argo Profiles, Uncheck Timeseries

Check Any parameters and Good data only. The select Refresh
to display the results.
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http://www.coriolis.eu.org/Data-Products
http://www.coriolis.eu.org/Data-Products
http://www.coriolis.eu.org/Data-Products

OPERATIONAL OCEANOGRAP

At sea monitoring

Maps comer
Tools
NEWS
2020-A0
12019
2019-A0
20/04/2018
2019-A0
20/04/2018

2017 Corious
ACTIVITY REPORT

14/06/2018

A @0

HOME ABOUT CORIOUS 'OBSERVING THE OCEAN DATA & PRODUCTS SCIENCE NEWS & EVENTS DOCUMENTATION

Catalogue Data & Products

Data Delivery Data useful to operational oceanography are obtained by diverse means including in-situ platforms (ships, drifters, floats, moorings, etc) and
- s S3tellites. They come in very different forms, from a single variable measured at a single point to multivariate four dimensienal collections of data

Submit data that represent data volumes from a few bytes to gigabytes.

Products In past 10 years, we have seen the emergence of assembly centres that :

> integrate data coming from a wide variety of platforms and providers (scientists, national data centres, satellte data centres and operational

agendies)

> get enough information from the originators to be able to know exactly how the data have been acquired and processed (documented and

commonly agreed QC procedures, history of the processing)
> distribute data and meta-data in agreed standardized formats (speaking the same language).

Thus the CORIOLIS Data Center relies on the distribution centers to consolidate a comprehensive and consistent set of real-time and delayed-time data

for operational oceanography and research. It also provides data sets for validation of satelite data missions
Coriolis data center is managed and operated by Sismer/Ifremer in Brest (France).

A

HOME

ABOUT CORIOLIS O

Catalogue

Data Delivery

Z Data selection

Mediterranean Data selection

Argo floats by WMO number

Argo floals interoperability
SEIvices

Argo DMQC Reporis

Argo : description of all floats

Argo bio floals from Coriolis

Data discovery and access
services

Eulerian networks, fixed buoys

Copemicus In Situ TAC

OpenDAP Thredds

Submit data

Products

At sea monitoring

Coriolis data service provides quality-controlled in-situ data in real-time and delayed modes. Managed data sets are mainly T-5 profiles and time
series fram profiing floats, XBT's, thermo-salinagraphs, drifting and moored buoys. Coriols is progressively integrated other parameters such as sea level
from European real-time tide gages, and ecosystem data  oxygen, chlorophyll and nutrients) from ferrybax , moering and gliders.

Data transmitted by floats are processed, checked for quality and distributed to the GTS and Intemet with minimum delay (24 h). The data service works
in close association with a scientific team to define procedures for data validation, quality control, formats and prodrts

Maps comer

Tools

The in situ data arriving to the CORIOLIS Data Center come from :

> France :

{

data from S0-Argo France, the french component of the Eur-Argo TGIR (Trés Grande Infrastructure ¢
data from SO PIRATA

data from 50 555

french data from drifting and moored buoys

data from SO MEMO

data from Gliders

data from french oceanographic vessels, ships from the French navy and french RECOPESCA fishing ba

et

t

{

> Europe:

~ European Centres partners of EuroGOOS project
European Centres partners of the SeaDataNet infrastructure
European Centres partners of the COPERNICUS in situ comp

{

t

bssnelin af L "

NetCDF Argo ¥

Staridate [&0 Enddate [
[o1/012017  [[o1012018 | s & = | e B
N | ] [@]xBT profies 0 ) | [¢*]orifting buoy 0
65 E 3 ] [®]cTo profiles 0 0 [ [c*|Tse 0
N ] [ |©|Glider profiles 0 0 [ |@ |Botties 0
|| |®|Sea mammal or Animal profiles |0 0 || | M |Fixed buoys & Mooring time series|0
|| |®|Fixed buoys and mooring profiles |0 0 O I(‘ Other time series & frajectories |0
|| |®|Other profiles 0 0
Press CTRL for muttiple selection
P;r@{neters including Platform codes (1000 max)

Vi
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Download data from Coriolis

To download all the selected data choose Download >
NetCDFEF Argo. Enter your email and wait for the notification
that the data is ready.

Then right-click on the link in the email and save to the folder

Documents\ODV\Data

Unzip the compressed the file to a folder named
pfl_india_argo_coriolis_delayed_good. There will be a series

of NetCDF (.nc) files in this folder.
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Data Selection Export

Email

Your email is optional, you will receive a delivery nofification when your data are ready.
For any questions, please contact - codac@ifremer fr

Extract your data

Data Selection Export

We are processing your data request
The data will be delivered at : fip:/fip ifremer.fr/ifi i ploo0501/DataSelection_20190630_081234_80254869 tgz
‘You can close this window.

Your data request from Coriolis Inbox x & 2
noreply@ifremer.fr 1:53 PM (7 minutes ago) Yy i
tome -

Your data file is available at
fip./iftp.ifremer friifremer/coriolis/tmp/co0501/DataSelection_20190630_081234_8028469 tgz,
you can find a description of your file format (NETCDF) on this page.

In publications, please use the following citation statement:
"These data were collected and made freely available by the Coriolis project and programmes that contribute to it (hitp-/iwww conolis. eu.org).”

Best regards,
Coriolis data management team.

Production time: 0:10:44 (HH:MI:S5)

‘Your data selection parameters are -

File format : NETCDF

Bounding box (latitudes longitudes) : 5N 10N - 65N 75N

Period (DD/MMIYYYY) : between '01/01/2017" and "01/01/2018"
Data type(s) - (Argo profiles’)

Required Physical parameters

* Quality : GOOD

* Processing Level :

OTGA-INCOIS Training Course on "Discovery and Use of Operational Ocean Data Products and Services", 01-05 Jul 2019



3. Import Data

To import the new Argo data,
select Import > Argo Formats
> Float Profiles

Select All Files from File type.

Navigate to the folder
Documents\ODV\Data
pfl_india_argo_coriolis_delayed

_good.

E Ocean Data View - Ch\Users\user\Documents\ ODV\data\argo_india

File Collection View Impert Export Tools Help
+| [m] [ ﬁ | 0DV Spreadsheet...
0DV Collection..,
Argo Formats i’ Float Profiles (netCDF v3.1)...
GOSUD netCDF v3... Float Trajectories (netCDOF v3.1)...
MedAtlas Formats...
SeaDatalNet Formats...
Sea-Bird CNV...
U5 NODC Formats  *
WHP Formats L4
ES select Argo_Profile File(s) 7 b4
Loak in: C:\Users\user\Documents\ODV\data > 0 Eﬁ @ E]
B Deskt... MName Size Type Date Modified 2
j D || sst_mon_meanf.nc 15..MB  ncFile  15-07-..14:25
=| Docu.. || == o
ko argo_india.odv 5KB odvFile 06-08-..16:10
0DV | |5 BATS bottle_data_1988-2016.0dv 3KB gdvFile 18-10-.. 11:44
ocean kS oDV COLLECTIO..14-37-1T).0dv 2KE odvFile 06-08-.. 1437
E training dataset 2018(1).0dv 1KB odvFile 15-07-..14:28
colle.. | /B training dataset 2018.0dv 1KB odvFile 29-03-.., 16:31
data E—E training_dataset_oxygen_Tu.odv 1KB odvFile 06-08-..10:18
EZ training_datase..n_Tuticorin.odv 1KB odvFile 08-08-..10:03
m_ DataSelection_2...936_7718611.tgz 1.9 MB tgz File  21-03-.. 1446
ﬂ pflindia_argo_..clayed_good.tgz i 27MB tgz File 30-06-... 14:01
=] analysis_log_20...26T10-20-05.b¢t  563..tes ttFile  26-06-... 10:44
=] analysis_log_20..26T12-20-58.¢  293..tes ttFile  26-06-. 12:21
=l analysis_log_20..26T13-01-286  310..tes ttFile  26-06-.. 13:01
=| model.bd 6.8 MB txtFile 04-07-..10:37
=] modelldbt 6.8MB ttFile 08-07-.12:18 v
File name: |pﬂ_\ndia_argo_coriolis_delayedjood.tgz | | Open
Files of type: | Al Files (%) Cancel



Import options

The Import Options dialog is
used to associate variables in
the import files with ODV
target variables. In most cases
the they will differ, so it will be
necessary to associate the two
sets of variables.

ODYV automatically associates
variables with matching labels
name and units) and marks the
associated variables with an
asterisk *.

Meta Variable Association

Source Variables Target Meta Variables
*  1: Cruise Assodate * Cruise ~
* 2 Station * Station
* 3 Type Convert *Type
* 4 Longitude [degrees_east] *Longitude [degrees_east]

* 5 Latitude [degrees_north] Set Default *Latitude [degrees_north]
= 6 Year *Year
* 7:Month Undo *Month
= 8:Day *Day
* 9 Hour *Hour
* 10: Minute *Minute
* 11: Second *Second
* 12 WMO Instrument Type *WMO Instrument Type
* 13: Type of Float *Type of Float
* 14 Serial Number * Serial Number
* 15: Firmware Version *Firmware Version
* 16: Vertical Sampling Scheme *Vertical Sampling Scheme
* 17: Data State Indicator *Data State Indicator
* 18: Project Name *Project Name
* 19: Principal Investigator *Principal Investigator
* 20: Data Centre *Data Centre w
P -SSR~ P -SSP~
21 of 27 variables used All 21 variables assodiated
Help Browse File Cancel
Impaort Options
Import Mode
Add [ Replace Station Data ~ [ Check for existing stations  Edit Matching Criteria. ..
Data Variable Assodation
Source Variables Target Data Variables
* 1: Pressure {original) [dedbar] Assodiate * Pressure {original) [dedbar] -
*  2: Pressure (adjusted) [decibar] * Pressure (adjusted) [decibar]
* 3 Temperature (original) [degrees_Celsius] Convert *Temperature (original) [degrees_Celsius]
* & Temperature (adjusted) [degrees_Celsius] *Temperature (adjusted) [degrees_Celsius]
= 5: Practical Salinity (original) [psu] Set Default * Practical Salinity (original) [psu]
* 6 Practical Salinity {adjusted) [psu] * Practical Salinity {adjusted) [psu]
Undo Dissolved Oxygen (original) [~Smr~#mal kg~"-~"1]
Dissolved Oxygen {adjusted) [~Sm~#mol kgre/-~
Undo All

All 6 variables used

Help

Particle backscattering {original) [me~"-~1]

Particle backscattering (adjusted) [me-n1]
Particle backscattering @ 532 nm (original) [m e -re
Particle backscattering @ 532 nm (adjusted) [me-r
Particle backscattering @ 700 nm (origingl) [mee-r®
Particle backscattering @ 700 nm (adjusted) [m~-~
Turbidity (original) [ntu]

Turbidity (adjusted) [ntu]

Beam Attenuation Coeffident [me~-re1]

Beam Attenuation Coeffident (adjusted) [mre-~1]
Chiorophyll-A {original) [mg mes"-~-"3]

Chlorophyll-A (adjusted) [mg mes"-~3]

CDOM (original) [ppb]

CDOM (adjusted) [ppb]

Nitrate (original) [~&m~#mol kge-r1]

Nitrate (adjusted) [~&m~#mol kgr-~"1]

Bisulfide (original) [~$mr#mol kges-n1]

Bisulfide (adjusted) [~Sme~#mal kgre"-n1] hd
< >

& of 40 variables assodated




ES Ocean Data View - C:\Users\user\ Documents\ODVicollections\pfl_all_india_wod13_temp
File Collection View Import Export Tools Help

+H 2 | B W\ S Default
a

R ———

m \ Station ID: 599

0 || Accession Number 599 s
ﬁ,ﬁ Cruise 2902609
"] Station 99 A A(C)

Positicn 68.426%E / 9.115°N
500 T Date 04 June 2017

Time 23%:18:20

Depth Range [m] [1-1956]

Bot. Depth [m]

500

1000 OCL Cruise Number

Originator's Cruise

Depth [m]

Originator's Station v

1500 ' st @
1: Depth [m] 1 ~
2: Temperature [degree.. 29.46
1000 3: Salinity [psu] 35772
4 Oxygen [pmol/kg]

5: Phosphate [pmol/kg]

355 36

Depth fm]

35
Salinity [psu]

6: Silicate [pmol/kg]
7 7: Nitrate [pmol/kg]
2 Nitrite [umol/kg]
% pH
10: Chiorophyll [pg/1]
11; Plankton/Biomass
12: Alkalinity [meq/I]
13: NO2+M0O3 [pmol/kg]
14: pCO2 [patm]
15: tC02 [mmel/11
Isosurface Values
Lengitude 68426 A~
2000 T T T T T Latitucle 9115

5 10 15 20 25 30 Time [yr] 2017425

Temperature [degrees_CJ Dy of Vear 155

68°E  T0E Depth [m] @ Depth [m]=first 1
Temperature [degrees_C] @ Depth [... 29.46

< >
Limibes Conm ] 30 Dmnile el e 77

Ready Canvas: 33.21/13.51 RW| - | 719/ 719: Default *

1500

5o o ooococo oo o oo oo

Ocean Data View

<

O Type here to search 0




4. Data Inventory

E Ocean Data View - C\Users\user\Documentst OOV collections'pfl_all_
File = Collection View Import Export Tools Help

+ Copy...

Create Snapshot...

To view the cruise inventory of the Move / Renarme..

Delete

collection, select Collection > Sort anl Condense

Delete Current Station

BI‘OWSG Inventoryo Delete Station Subset

Browse Info File

By default this file will be saved Browse nertory

Browse Log File

PrOduCtS > Products > ODV > Add Log File Comment

Create Overview Plots

pﬂ_all_llb eI‘ia_WO d 13. D ata Identify Key Variables...

Good Coverage Criteria...

>(ruiselnventory.txt.

Properties L4

You can open the file in

Excel/Notepad



Part 2:
Import ascii data into ODV



1. Import data

\\\\\\\\\\\\\\
55555

ODYV requires mandatory

000000

metadata, such as the geographic

555555
EEEEEEEEEEEEEEE
rrrrrrrrrrrrr

location of a station, the dateof ==

observation, and the names of the
station and cruise

Select I'ile > Open then navigate to

Primary Variable: | Oxygen

the training_dataset_oxygen.txt
file in the Documents\ODV\Data
folder and open it. The Spreadsheet

File Properties dialogue shows the
data that will be imported. Select o
OK.

Remove ID from data variable list
and select oxygen as primary
variable




2. Associate variables

The next step is to match-up
between the incoming data (in the
spreadsheet) and the fields in the
ODV collection structure. Already
assoclated variables are marked
by asterisks (*).

Associate ID with cruise

Select OK.

Source Variables Target Meta Variables
1: Longitudh Associate Cruise
2: Latitude Statio
3: Date Convert Type
41D *Longitude [degrees_east]
5: Depth Set Default *Latitude [degrees_north]
&: Oxygen Year
Undo Month
Day
Hour
Minute
Second
2 of 6 variables used 2 of 11 variables assodated
Help Browse File Cancel
Import Options
Import Mode
Add [ Replace Station Data ~ [ Check for existing stations  Edit Matching Criteria...
Data Variable Assodation
Source Variables Target Data Variables
* LDate Assodate *Date
21D *Depth
* 3:Depth Convert * Oxygen
* 4 Oxygen
Set Default
Undo
Undao All
3 of 4 variables used All 3 variables associated

Help




3. Task:

E Ocean Data View - C\Users\user\Documents\ODV\collections\tuticorin - X
File Collection View Import Export Tools  Help
+H 9 (¢ H W/ Defalt B\ Station ID: 4
|| Accession Number 4
Oxygen Cruise 4
0 200 Station 4(8)
H Position T8.915°E/ 8.027°N
1 : Date
. -
¢ : Time
50 2 150 Oxygen Range [22.33 - 191.84]
.
. : Y —
L]
£ . 1: Date 2.017e+7 1
B 100 100 2 1
Q 3: Depth 100,00 1
1 * 4; Oxygen 34.03 1
. drvd: Section Distance [k.. 102,04 1
150 3 50 Isosurface Values
*|5 Longitude 78915
B
E & Latitude 8.027
ME
E Time [yr]
200 ol 1] Day of Year
50 100 150 Date @ Oxygen=first 20170200.00
Section Distance [km ID @ Crygen=first
Depth @ Oxygen=first 20000
Oxygen @ Oxygen=Ffirst 2233
T8.2°E T8.4°E T8.6°E T8.8°E T9E T9.0°E
w
< b3
Ready Window 1: 76.04 /3132 RW| -|- |- |5/ 5: Default*
o 20:01
O Type here to search 0 ~ T ENG N

01-07-2019



4. Generic ODV spreadsheet format

If you plan to use ODV to regularly import spreadsheet data,
it is recommended to use a standard ODV template.

The Column Header Row contains a label for each column of

the file.

The csv file should contain columns of Longitude, Latitude
and atleast any one variable, along with their headers.

The leftmost columns are the metadata columns, followed by
the data column pairs (which can include a qualitying flag
column).



Generic ODV spreadsheet format

The column Type is used to designate the instrument used to
collect the data, e.g. bottle, C'TD, etc.

The following metadata column header labels are mandatory and

should be included EXACTLY as written:

Cruise, Station, Type, yyyy-mm-ddThh:mm:ss.sss,
Longitude [degrees_east, Latitude [degrees_north], Bot.
Depth [m]

The metadata is followed by the data variables.

Each column for a data variable can have an optional quality flag

QF. Depth [m], QF Temperature [°C], QF, Salinity [PSU], QF, etc



5. To import a generic spreadsheet data

Open ODV. To load in the data, you may either access the File
menu and click Open and select your file or simply drag your
text file into the window itself.

ODYV will then indicate how many stations have been imported
and from what directory. Click OK to proceed.

Depending on the size of the data file, you may have to perform
Sort and Condense if the data was poorly sorted. Click Yes if
you are prompted to do so.



Part 3:
Import NETCDF data



Open netcdf data

Goto Ifile > Open and select the NC file

sst_mon_mean

Netcdf setup wizard shows up showing
the input variables, click NEX'T after

the the select dimension.

Under Associate meta-variables, Add

SST to the right hand side list by

clicking on >=>

Select time as days since 1981 as
primary variable as primary variable
and in the last step select the option to
subset the time dimension.

K= open ..

X

Look in: C:\Users\user\Documen t=\0ODV\data -0 Q0 ﬁﬁ @ E]
! Desktop MName Size Type Date Modified =
E2 Docums sst_mon_mean.Data Fil...der 15-07-... 1438

sst_mon_mean1.Data Fil..der 153-07-..17:11

opv sst_mon_mean2.Data Fil...der 15-07-..17:23
UUUUU Test dataset Fil..der 05-07-...09:59
training dataset 2018(1).Data Fil...der 15-07-... 1428

collectic || training dataset 2018.Dzta Fil..der 29-03-.., 16:31
V2018-09_0DV Fil..der 04-07-.,13:30

WoADS Fil..der 10-01-.., 11:49

Woa13 Fil..der 29-06-... 15:00

| ] 1979_pac.nc 34MB ncFile 20-07-.. 10:50

| ] 1981_pac.nc 19MB ncFile  30-07-..11:15

|_] 199112300000-199201060000.nc 17MB ncFile  30-07-.. 18:03

|| rem02873.nc 17KB ncFile  20-04-.. 21014

| | rem02903.nc 25KB ncFile  20-04-..21:23

» ||| sst_mon_mean2.nc 15.MB ncFile 15-07-...14:25

File name: |sst_mon_mean2.nc | I Open

Files of type: |netCOF Files (*.nc *.cdf *.grd) Cancel

NetCDF Setup Wizard

Select Dimensions (Step 1 of 4)

NetCDF dimensions Corresponding netCDF variables

lon[360] lat [degrees_north]

lat[180] lon [degrees. ]

time[1542] time [days since 1891-1-1 00:00:00]

[degC]
All 3 dimensions sel lected
View NetCDF Header
Help Back Finist Cancel




NetCDF Setup Wizard

Associate Meta Variables (Step 2 of 4)

NetCDF variables

* 1: lat [degrees_north]; var=lat
* 2: lon [degrees_east]; var=lon
* 3: time [days since 1891-1-1 00:00:00]; var=time Convert
* 4 sst [degC]: var=sst

Meta variables

Assodate Cruise
Station
Type
* Lengitude [degrees_east]
* Latitude [degrees_north]
* Year
* Month
* Day
*Hour
* Minute
* Second
* st [degC]

Set Default

Undo

E=S

All 4 variables used 9 of 12 variables assocated

Help < Back Finish Cancel

MetCDF Setup Wizard

Subset Dimensions (Step 4of 4)

54800 stations. You can reduce the number of stations by subsetting
one or mare dimensions or by zooming into the map.

NetCDF dimensions
lon[360] use[0:1:359]
1at[180] use[D:1:179]
time[1542] use[(:1:1541]

Subset Dimension Zoom into Map Ful Domain

Help < Back Mext >

Subset the lat and lon dimensions

MetCDF Setup Wizard

Select Primary Variable (Step 3 of 4)

Available netCOF dimensions

time [days since 1891-1-1 00:00:00]

®) Use selected variable
O use decmal date/time (header)

O Use dummy variable

Help < Back

Finish

Cancel

Animation - |sosurface

time [days since 1891-1-1 00:00:00]= ...

Isosurface Values

Start: [0 |

Step: [31 |

Mumber of frames: |151

a4k

Use Available Coordinate Values

Style
[ Adjust Z value range
[ Adjust Z color mapping

to use all the values in

eridded data and the time dimension to include values upto

monthly timesteps

the
150




* To plot in surface mode, go to View > Layout Templates and select

E Ocean Data View - J\ODV data files\sst_mon_mean.nc
File Collection View Import Export Tools Help

+ 9 (¢ H W /S Default B\

sst [degC] @ time [days since 1891-1-1 00:00:00]=first

>

- X
Station ID: 1
Cruise sst_mon_mean.nc
Station 1(C)
Position 0.5°E/ 89.5°N
Date 01 January 1891
Time 00:00:00

time Range [days since 18...

[0.0000 - 46902.0000]

sst [degC] -1.80
sample: 1/ 1542 =X
1: time [days since 1831...  0.0000 1
2: lat [degrees_north] 89.50 1
3: lon [degrees_east] 0.50 1
4: sst [degC] -1.80 1
Isosurface Values
Lengitude 0.500
Latitude 89.500
Time [yr] 1891.000
Day of Year 1

sst [degC] @ time [days since 1891-1-.. -1.80

Ready Canvas: 27.61/5.65

£ Type here to search

- | 64800 / 64300 Default *

Links ~ o 71 o) ENG

7:23

01-09-2020 Ez




Change plot label

Go to properties and untick the
Automatic Label option

To change the figure title click outside
the canvas near the current title and

Add Graphic Objects > Annotation

Then add the text Monthly Mean SST
during January 1901

General Data Display Style Contours Color Mapping DIVA Settings

Palette: |Odv
Background color: | (none)

Highlighting style: |curve & dots

Font base size [pt]: |{automatic)
Font size factor: 100 % =

Axis Style

[ Apply to all windows Default Settings

Cancel

Annotation - Properties

Text: |SST monthly mean| |
Position

X: [13.2528 ¥i [15.9874

Alignment
X: |center ¥: | cente

Properti
Text color: .U - Background:  (none)

Font size: |14pt = Frame color: |{nane)
Orientation: Frame width: | (none)

Owner: |Canvas = Coordinates: | Canvas
[ Pre-data plot [] Clip to window Allow dragging

Cancel




Animations

Right click on the figure,

Go to Extras >

Animation > Isosurface

(Create monthly plots

Redraw

Save Plot As...

Save As Interrupted Map...

Zoom
Z-Zoom

Auto-Zoom In

Auto-Zoom Out

Move to Foreground

Move to Background

Full Range
Set Ranges

X-Variable
¥-Variable
Z-Variable

Extras

Sample Filter
Properties...

F5
Ctrl+5

Ctrl++

Ctrl+-

Ctrl+F

Alt+P

Metadata Time...

Metadata Time of Year...

Variable Range...

lsosurface...

To plot sst during the months May

1891, January 1892 and January
1901, go to View > Isosurface

Statistics...
Clipboard Copy

1D Estimaticn...

2D Estimation...

Find Qutliers (Field Check]...

Define Patch

lsopycnals...

Add Graphics Object

Add Graphics Object from File
Manage Graphics Objects...

Export as Graphics Object

Animation

New

Already Defined

Isosurface Variables

4: sst [degC] *

Animatien - Isosurface

time [days since 1891-1-1 00:00:00] = ...

Isosurface Values

start: [0

Step: [31

Number of frames: |1542

v

F4
Ctrl+C

Use Available Coordinate Values

Style
Adjust Z value range
[ adj g

[ Adjust 2 color mapping

Cancel

5: time [days since 1891-1-100:00:00] ~ = 36520000

Add

Longitude
Latitude
Time [yr]

variables and add SS'T (@ time = 120,
305 and 3052 respectively

Go to Layout Templates > 3 Surface

Day of Year

sst [degC] @ Dummy =first

sst [degC] @ time [days since 1891-1-1 00:00:00]=120.0000
sst [degC] @ time [days since 1891-1-1 00:00:00]=365.0000

‘sst [deqC) @ time [days since 1891-1-1 00:00:00]=3552,0000

Delete Edit

Help

V-5ync

5-5ync

Cancel



sst [degC] @ time [days since 1891-1-1 00:00:00]=first sst [degC] @ time [days since 1891-1-1 00:00:00]=120.0000

sst [degC] @ time [days since 1891-1-1 00:00:00]=365.0000

Go to I'ile > Save canvas as to get the above layout in jpeg format

By clicking on any data point in any window, the corresponding

time will be shown in the left top window labelled STATION 1D



Other options

* Go to Collections > Browse info file to see the properties of the

netcdf file

Task

* Plot a section in Arabian Sea with section distance on x-axis,
time on y axis and sst on z axis with DIVA gridding. This is
similar to a hovmoller diagram. Notice the warming along
equatorial region.



Part 4:
Timeseries data



Metadata and Data Variables

* Select File > Open then navigate to the = o B
timeseries_trial.csv file in the

PrimaryVarhin

Documents\ODV\Data folder and open

Data Variables

L]
Time New
1 I Depth
L]

Sealevel Edit

e Match the meta variables and data
variables, and click O K.

Primary Varible: | Time hd

* Select timeseries as datatype and

as primary variable

Import Mode

Add / Replace Station Data ~ [ Check for existing stations  Edit Matching Criteria...

Data Variable Assocation

. . Source Variabl Target Data Variabl
Meta Variable Association oures ferees croet et ferenis
* 1:Tme Associate | | *Time
= 2 Depth *Depth
Source Variables Target Meta Variables * 3:SeaLevel Convert | *SeaLevel
*  1: Station Associate Cruise Set Default
! = 2: Longitude = Station
Collection Properties * 3 Latitude Convert Type s
4 Time *Longitude [degrees_east] Undo Al
Data Field: [Ocean - 5: Depth Set Default Latitude [degrees_north]
6: Sea Level Year
Data Type: |TimeSeries = Undo Month
Day
Primary Variable: | Time i Hour
Minute
Second
e Coce
All 3 variables used Al 3 variables associated
- . Help Cancel
3 of 6 variables used 3 of 11 variables assodated
Help Browse File Cancel




S Ocean Data View - CA\Users\user\Documents\0DV\data\timeseries_triall

File Coellection View Import Export Tools Help
+| 2] O] B W S Default B\ Station I0: 1
. Accession Number 1
12 Cruise timeseries_trial1.cav
| Station 1(B)
10 Position 92.197°E / 20.964°N
i Date
1 Time
8 Time Range [1.00 - 19.00]
=
B 1 sample:1/19 e
8 6 1: Time 1.00 1
] 2: Depth 1.01 1
3: Sea Level 0.08 1
4 H
/ = Isosurface Values
J @
/‘ g Longitude 92.197
2 5 Latitude 20.964
/ g Tirme [yr]
0 5 10 15 20 Day of Year
Tl'me Time @ Time=first 1.00
Depth @ Time=first 1.01
Sea Level @ Time=first 0.08
0.081
21°N 0.08 +\K1 [
3 o.079 ”“x\ /
[ I~ /
20.95°N 0.078 :
\\‘ E
1 g
0.077 \\ [
F .
F N &
20.9°N 5 0 5 10 15 20
8 Time
92.15°E v
< >
Ready

O Type here to search

~ ois T o

ENG

10:19
07-08-2019

[55]



Part 5:
Vector dataset



Open data

aaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

Select I'ile > Open then navigate to the : e
training_dataset_vector.csv file in the i
Documents\ODV\Data folder and open
Match the meta variables and data

variables, and click O K.

Select general as datatype and W5 as

Collection Properties

primary variable

Data Field: | Ocean
Data Type: |GeneralType

Primary Variable: | WS [Km/hr]



S Ocean Data View - CA\Users\user\Documents\ODV\data\training_dataset_vector

File Coellection View Import Export Tools Help
+ ] [o] B W] / Default % Station I0: 1
Accession Num... 1
Cruize training_dataset_vector.csv
Station 3B
Position 80°E/ 4°N
WS [Km/hr] @ WS [Km/hr]=firs Date 28 January 2006
i = 20 Time
WS Range [Km/.. [17.30-17.30]
¥ —— - | Q
< Sample:1/1
17.5
1: Mo 1626.00 1
EQ — 2 Depth 1.00 1
° 3: Time 2006.00 1
. 't 15 4 WS [Km/hr] 17.50 1
. Ers | I 5: Wind Direction [De... 90,00 1
- d n Irection (= 3
EQ L] L] ° /| 7.
o [ B: U wind [km/hr] -7.84 1
- . 12.5 7: V wind [km/hr] 15.64 1
.
10°5 . . 10°S . Isosurface Values
L Y Longitude 80.000
L . 10 Latitude 4,000
3 Time [yr] 2006.074
20°s | q ’ \
B f . Day of Year 28
H bo a § 1 75 Mo. @ WS [Km/hr]=first 1626.00
60°E TO°E 80°E 90°E Depth @ WS [Km/hr]=first 1.00
20°S Time @ WS [Km/hr]=first 2006.00
¥
[ x WS [Km/hr] @ WS [Km/hr]=first 17.50
a
SEH 5
[] =
L] | g
- L] =
o
&
eJ25
60°E 80°E 90°E
<
Ready Window 1: 74.9°E / 1.6°N

O Type here to search

~ oid T )] ENG




Plot vector

General | Data Display Style

Data Display Style

(® Original data

Create 1sosurface variables of u ||

Contours

Color Mapping ~ DIVA Settings

and v at depth = first (surface) e

Right click on the figure, go to ‘
Properties > Display Style >

Select Arrows and assign U an V |

Data Mark Style

velocities as X and Y respectively.

[ Apply to all windows

Change scale to 20, or according
to the desired arrow length.

Help

Arrow Properties Window 1

Xf¥ Components

X: U wind [km/hr] @ Depth=first

i |V wind [km/hr] @ Depth=first

=

Line width: | thin

Color: . o

G
Quality limit
Color
|_E%
Default Settings
oK Cancel




E Ocean Data View - C\Users\user\ Documents\ODV\data\training_dataset_vector(1)

File Coellection View Import Export Tools Help
+| [0 | m ] ;r Default ST nieil
Accession Num... 1
Cruize training_dataset_vector.csv
Station 3B
Position 80°E/ 4°N
Wind Direction [Degrees] @ WS [Km/hr]=firs Date 28 January 2006
i = Time
/Q WS Range [Km/.. [17.30-17.30]
Y Sample:1/1 | Q
A 1: Depth 1.00 1
EQ S— 2: Time 2006.00 1
/ 3t WS [Km/hr] 17.30 1
" st 4: Wind Direction [De... %0.00 1
. —— s
- | 5: U wind [ken/hr] -7.84 1
EQ 1 -— /
[ [ - B: V wind [km,/hr] 15.64 1
—_—
¥ o5 Isosurface Values
.
Lengitude 20.000
10°S 10°S -
7 = \ Latitude 4000
- " . Tirme [yr] 2006.074
e E Day of Year 28
20°5 b H
4 3 2 ‘ / Depth @ WS [Km/hr]=first 1.00
5 oo 2 1 ’/ Time @ WS [Km/hr]=first 2006.00
60°E 70°E 80°E 90°E 4 WS [Km/hr] @ WS [Km/hr]=first 17.50
o. — Wind Direction [Degrees] @ WS [K.. 90.00
20°S 9
¥
o \ v z U wind [ken/hr] @ Depth=first -7.84
a
= Vwind [km/hr] @ Depth=first 15.64
=
! w T s
=
—= 20 km/hr ‘
- (=]
60°E 70°E 80°E 90°E
<
Ready

O Type here to search

~ oid T )] ENG

a7




Part 6:
Model data



Import data

Select I'ile > Open then navigate to the
model data_timeseries.csv file in the Documents\ODV\Data
folder and open it.

Match the meta variables and data variables, and click O K.

Select general as datatype and depth as primary variable



e

+

E Ocean Data View -

Collectior ie mport  Exp

ort

Tools

Rnelp

ChUsers\user\Documents\ 0DV data\model_data

o [ B W/

Default

B\

24°N

22°N

20°N

18°N

Depth @ Depth=first

2500
2000
1500

7000

500

16°N

86°E

Station ID: 1

Accession Number
Cruise

Station

Puosition

Date

Time

Depth Range

1

model_data.csv
1(B)

92.197°E / 20.964°N

[0.00 - 0.00]

Sample:1/1

1: Depth

2: Sea Level

0.00 1
0.08 1

Isosurface Values

Lengitude

Latitude

Time [yr]

Day of Year

Depth @ Depth=first

92197
20.964

0.00

Sea Level @ Depth=first 0.08

Ready

O Type here to search

Window 1: 88.66°E / 20.89°N RW| -|- | - | 118862 / 118862: Default ™

Vafild

ENG




View - Ch\Users\user\Documents\ODV\data\model_data — *

+ 9 [ # W [/ Default B\ Station ID: 1

. Accession Number 1
Cruize model_data.csv
Station 1(B)
Position 92.197°E / 20.964°N
=i Dat:
Sea Level @ Depth=first e
Time
o —, —, —
24°N Depth Range [0.00 - 0.00]
0.08 | set puis Ranges Samplez1/1 | Q
¥ Axis: Longitude 1: Depth 0.00 1
T 2: Sea Level 0.08 1
o
24°N 22°N Maximum: |94, 5707 Isosurface Values
0.06 Longitude 92,197
Latitude 20.964
22°N Tirme [yr]
¥ Axis: Latitude Day of Year
20N - g © et o
it Sea Level @ Depth=first 0.08
18°N
6N 0.02 Z Axis: Sea Level @ Depth=first
18°N
86°E 88°E  90°E  9E  9LE
Concel
0
16°N
86°E 88°E 90°E 92°E 94°E
v
< >
Ready RW]| -|- |- 118862 / 118862: Default *

Q Type here to search ] < ~ @ T i) ENG

o7




Create isosurface variable as sea level at time equals 2.

E Ocean Data View - C\Users\user\Documents\ 0DV data\model_data_timeseries
File Collection View Import Export Tocols Help

+ 9 (¢ H W /S Default B

Sea Level @ Time=2.00
24°N — — —

0.15

22°N

20°N

0.05

18°N

16°N

86°E 88°E 90°E 92°E 94°E

Station ID: 1

Accession Num... 1

Station 1(B)

Date

Time

Puosition 92.197°E / 20.964°N

Time Range [1.00 - 1.00]

Cruize model_data_timeseries.csv

Sample:1/1

1: Time
2: Depth

3: Sea Level

1.00
0.00
0.08

Isosurface Values

Longitude

Latitude

Time [yr]

Day of Year

Time @ Time=first
Depth @ Time=first
Sea Level @ Time=first
Sea Level @ Time=2.00

92,197
20.964

1.00
0.00
0.08

Ready

O Type here to search

~ oid T )] ENG

11:14
07-08-2019
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